Hearts of Iron III: For the Motherland

HOI 3 FTM wont run in windows 8

By trevc68@telus.net posted 21st Aug 2013

I have bought a new computer that comes with windows 8. I downloaded HOI3, installed it and it ran. Then I downloaded and installed HOI3 Semper Fi, it ran. Then downloaded HOI3 FTM and began installation. At the very end I received this message;

A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine.

I clicked ok and the installation finished. I tried to run HOI3 but it got hungup. I went to the Microsoft website and tried to install Microsoft Visual C++ 2010 Redistributable Package (x86) which is what was recommended but while trying to install it that it also gave the same error message as above. I am trying to work my way up installing HOI3 TFH which I have already purchased. All versions were bought and downloaded from GG.

Thanks

Replies

By NeroReaver posted 21st Aug 2013

Does the game support windows 8?

By trevc68@telus.net posted 21st Aug 2013

A logical question. Since the two earlier versions of HOI3 ran I assumed that FTM would also run. You are right it doesn't say WIN 8 in sys req's. Any chance there will be a fix so that these games will run in WIN 8? Please!

By jkfrench posted 26th Aug 2013

I'm on Windows 8 Pro 64-bit and have The HOI3 Collection ... which is just FTM with some additional Sprite Packs thrown in ... and it works fine ... and I received the same message about Visual C++ 2010 redistributables during installation (it's not a problem).

A couple things to try ...
1) Try launching as Administrator (instead of left clicking on the icon, right-click on it and select Run as Administrator) ... see if that helps any.
2) Make sure you are patched to at least version 3.05 (there are a coupe 3.06 beta patches too, but there are some issues with some of the Official Mods with the beta versions and the 3.05 version is recommended by most if you have them)

By paradigmalex posted 26th Aug 2013

I had similar problems under win7 and had to uninstall manually vcredist, then install FTM. The newer version locks the installer. Hope this helps.

Answer this question

You need to be logged in to be a GameTutor

Your cart is empty
JOIN US
SIGN IN